Friday, August 12, 2011

Avaya DHCP Option 242 & 176

Getting your Avaya phones to auto VLAN in the correct DHCP scope isn't complicated below are 2 strings per DHCP scope you may need.  In this example I have used a cisco switch as the DHCP server.
The first configuration shows the User network where the phones will initially boot into.  The phones will pick up either option 176 or 242 from the options 176 or 242 depending the model of handset. L2QVLAN=11 will tell the phone to tag its packets with this network (the voice vlan).
!
interface vlan 10
Desc USER NETWORK
ip address 10.10.10.1 255.255.255.128
no shut
ip ospf 1 area 10
!
ip dhcp pool USER NETWORK
   network 10.10.10.0 255.255.255.128
   default-router 10.10.10.1
   dns-server 10.10.10.12
   option 176 ascii L2QVLAN=11
   option 242 ascii L2QVLAN=11
!
The next Scope will be defined for your voice network and define options 242 & 176 for the handsets, this option will tell you handsets where your call manager server is (MCIPADD) 10.10.20.131 & 10.10.30.131 in this example.  The HTTP directory (HTTPDIR) where you store your 96xxsettings.txt and the server ip address of your HTTP server (HTTPSRVR) 10.10.40.131 in this example.
!
int vlan 11
Desc VOICE NETWORK
ip address 10.10.10.129 255.255.255.128
no shut
ip ospf 1 area 10
!
ip dhcp pool VOICE NETWORK
   network 10.10.10.128 255.255.255.128
   default-router 10.10.10.129
   dns-server 10.10.10.12
   option 176 ascii MCIPADD=10.10.20.131,10.10.30.131,MCPORT=1719,HTTPDIR=/phones/96xx/,HTTPSRVR=10.10.40.131
   option 242 ascii MCIPADD=10.10.20.131,10.10.30.131,MCPORT=1719,HTTPDIR=/phones/96xx/,HTTPSRVR=10.10.40.131
!
This is how you can configure your switch ports
!
int gi1/0/1
switchport
switchport host
switchport access vlan 10
switchport voice vlan 11
auto qos voip trust
spanning-tree bpduguard enable
no shut
!

No comments:

Post a Comment